aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorWilmer van der Gaast <wilmer@gaast.net>2010-06-05 18:35:39 +0100
committerWilmer van der Gaast <wilmer@gaast.net>2010-06-05 18:35:39 +0100
commit477250038a91c6877838cbd7f0d32b839f64824d (patch)
treef7479147e3f8ac92442ca75795832464fbcea51f /debian/rules
parent4c0388134ff88b72e343bd07013554480c2a4ef7 (diff)
Put in the necessary hacks to make version number spoofing work again.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 6 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 8ccb181b..f2ede2cf 100755
--- a/debian/rules
+++ b/debian/rules
@@ -19,11 +19,11 @@ build: build-stamp
build-stamp:
dh_testdir
- mkdir debian/build-native
+ mkdir -p debian/build-native
ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent $(BITLBEE_CONFIGURE_FLAGS)
$(MAKE) -C debian/build-native
- mkdir debian/build-libpurple
+ mkdir -p debian/build-libpurple
ROOT=$$PWD; cd debian/build-libpurple; $(BITLBEE_CONFIGURE_VERSION) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --purple=1 $(BITLBEE_CONFIGURE_FLAGS)
$(MAKE) -C debian/build-libpurple
@@ -61,7 +61,7 @@ binary-common:
dh_testroot
dh_installdocs --link-doc=bitlbee-common
- dh_installchangelogs
+ dh_installchangelogs doc/CHANGES
dh_installexamples
dh_installdebconf
dh_installinit
@@ -79,9 +79,10 @@ ifeq ($(DH_OPTIONS),-a)
endif
dh_shlibdeps
ifdef BITLBEE_VERSION
- dh_gencontrol -- -v1:$(BITLBEE_VERSION)-0
+ echo source:Version=1:$(BITLBEE_VERSION)-0 > debian/substvars
+ dh_gencontrol -- -v1:$(BITLBEE_VERSION)-0 -Vbee:Version=1:$(BITLBEE_VERSION)-0
else
- dh_gencontrol
+ dh_gencontrol -- -Vbee:Version=$(shell dpkg-parsechangelog | grep ^Version: | awk '{print $$2}' | sed -e 's/+[^+]*$$//')
endif
dh_md5sums
dh_builddeb