aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authordequis <dx@dxzone.com.ar>2018-03-19 14:02:01 -0300
committerdequis <dx@dxzone.com.ar>2018-03-19 14:02:01 -0300
commitac3b8ff3752e20c087fc3ad0fddb277e0a4e6b33 (patch)
tree3f3885f9fc603ae150cced66532f56fc9ea980ce /debian/rules
parent1de945b2b2ad5506f7909ced21f923ea8a62a09c (diff)
debian: remove skype plugin stuff
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 1 insertions, 17 deletions
diff --git a/debian/rules b/debian/rules
index e31e0710..3cb71e67 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,11 +8,8 @@
#
# Include the bitlbee-libpurple variant and OTR plugin by default.
-# Don't build skype by default since it depends on deleted/non-free
-# packages. Need to at least get python-skype back into Debian.
BITLBEE_LIBPURPLE ?= 1
BITLBEE_OTR ?= plugin
-BITLBEE_SKYPE ?= 0
BITLBEE_CONFIGURE_FLAGS ?=
DEBUG ?= 0
@@ -29,10 +26,6 @@ ifneq ($(BITLBEE_OTR),plugin)
DH_OPTIONS += -Nbitlbee-plugin-otr
endif
-ifneq ($(BITLBEE_SKYPE),plugin)
-DH_OPTIONS += -Nbitlbee-plugin-skype -Nskyped
-endif
-
CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
@@ -51,7 +44,7 @@ build-stamp:
dh_testdir
mkdir -p debian/build-native
- ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent --otr=$(BITLBEE_OTR) --skype=$(BITLBEE_SKYPE) $(BITLBEE_CONFIGURE_FLAGS)
+ ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent --otr=$(BITLBEE_OTR) $(BITLBEE_CONFIGURE_FLAGS)
$(MAKE) -C debian/build-native
ifeq ($(BITLBEE_LIBPURPLE),1)
@@ -85,20 +78,11 @@ install: build
$(MAKE) -C debian/build-native install-etc install-doc DESTDIR=`pwd`/debian/bitlbee-common
$(MAKE) -C debian/build-native install-dev DESTDIR=`pwd`/debian/bitlbee-dev
$(MAKE) -C debian/build-native install-plugin-otr DESTDIR=`pwd`/debian/bitlbee-plugin-otr
- $(MAKE) -C debian/build-native install-plugin-skype DESTDIR=`pwd`/debian/skyped
ifeq ($(HAS_DH_SYSTEMD),1)
$(MAKE) -C debian/build-native install-systemd DESTDIR=`pwd`/debian/bitlbee-common
endif
-ifneq ($(BITLBEE_SKYPE),0)
- mkdir -p debian/bitlbee-plugin-skype/usr
- mv debian/skyped/usr/lib debian/bitlbee-plugin-skype/usr
-
- mkdir -p debian/skyped/usr/share/man/man1
- mv debian/bitlbee-common/usr/share/man/man1/skyped* debian/skyped/usr/share/man/man1
-endif
-
ifeq ($(BITLBEE_LIBPURPLE),1)
$(MAKE) -C debian/build-libpurple install-bin DESTDIR=`pwd`/debian/bitlbee-libpurple
ln -sf debian/bitlbee.prerm debian/bitlbee-libpurple.prerm