aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorMarius Halden <marius.h@lden.org>2018-04-19 10:23:08 +0200
committerMarius Halden <marius.h@lden.org>2018-04-19 10:23:08 +0200
commitdb02ac8971379f9fee2f3a618bb08b8076d1a83d (patch)
tree0e7d46bad6162509300aa73ae6d77e571a5b26d0 /debian/rules
parent6dc54671e368d03ed447d0fbd2d662af6c36b7fd (diff)
parent246b98bbdf221448fd7a638fea04373ed1612de5 (diff)
Merge branch 'master' into patched-master
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules30
1 files changed, 7 insertions, 23 deletions
diff --git a/debian/rules b/debian/rules
index e31e0710..8cdb9628 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,11 +8,8 @@
#
# Include the bitlbee-libpurple variant and OTR plugin by default.
-# Don't build skype by default since it depends on deleted/non-free
-# packages. Need to at least get python-skype back into Debian.
BITLBEE_LIBPURPLE ?= 1
BITLBEE_OTR ?= plugin
-BITLBEE_SKYPE ?= 0
BITLBEE_CONFIGURE_FLAGS ?=
DEBUG ?= 0
@@ -29,10 +26,6 @@ ifneq ($(BITLBEE_OTR),plugin)
DH_OPTIONS += -Nbitlbee-plugin-otr
endif
-ifneq ($(BITLBEE_SKYPE),plugin)
-DH_OPTIONS += -Nbitlbee-plugin-skype -Nskyped
-endif
-
CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
@@ -51,12 +44,12 @@ build-stamp:
dh_testdir
mkdir -p debian/build-native
- ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent --otr=$(BITLBEE_OTR) --skype=$(BITLBEE_SKYPE) $(BITLBEE_CONFIGURE_FLAGS)
+ ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent --otr=$(BITLBEE_OTR) --systemdsystemunitdir=/lib/systemd/system $(BITLBEE_CONFIGURE_FLAGS)
$(MAKE) -C debian/build-native
ifeq ($(BITLBEE_LIBPURPLE),1)
mkdir -p debian/build-libpurple
- ROOT=$$PWD; cd debian/build-libpurple; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --purple=1 $(BITLBEE_CONFIGURE_FLAGS)
+ ROOT=$$PWD; cd debian/build-libpurple; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --systemdsystemunitdir=/lib/systemd/system --purple=1 $(BITLBEE_CONFIGURE_FLAGS)
$(MAKE) -C debian/build-libpurple
endif
@@ -85,20 +78,11 @@ install: build
$(MAKE) -C debian/build-native install-etc install-doc DESTDIR=`pwd`/debian/bitlbee-common
$(MAKE) -C debian/build-native install-dev DESTDIR=`pwd`/debian/bitlbee-dev
$(MAKE) -C debian/build-native install-plugin-otr DESTDIR=`pwd`/debian/bitlbee-plugin-otr
- $(MAKE) -C debian/build-native install-plugin-skype DESTDIR=`pwd`/debian/skyped
ifeq ($(HAS_DH_SYSTEMD),1)
$(MAKE) -C debian/build-native install-systemd DESTDIR=`pwd`/debian/bitlbee-common
endif
-ifneq ($(BITLBEE_SKYPE),0)
- mkdir -p debian/bitlbee-plugin-skype/usr
- mv debian/skyped/usr/lib debian/bitlbee-plugin-skype/usr
-
- mkdir -p debian/skyped/usr/share/man/man1
- mv debian/bitlbee-common/usr/share/man/man1/skyped* debian/skyped/usr/share/man/man1
-endif
-
ifeq ($(BITLBEE_LIBPURPLE),1)
$(MAKE) -C debian/build-libpurple install-bin DESTDIR=`pwd`/debian/bitlbee-libpurple
ln -sf debian/bitlbee.prerm debian/bitlbee-libpurple.prerm
@@ -119,12 +103,12 @@ binary-common:
for p in bitlbee bitlbee-libpurple bitlbee-dev bitlbee-plugin-otr; do rm -r debian/$$p/usr/share/doc/$$p && ln -s bitlbee-common debian/$$p/usr/share/doc/$$p || true; done
dh_installdebconf
ifeq ($(HAS_DH_SYSTEMD),1)
- dh_systemd_enable --no-enable bitlbee.socket
- dh_systemd_enable bitlbee.service
- dh_installinit --init-script=bitlbee
- dh_systemd_start
+ dh_systemd_enable -p bitlbee-common --no-enable bitlbee.socket
+ dh_systemd_enable -p bitlbee-common bitlbee.service
+ dh_installinit -p bitlbee-common --init-script=bitlbee
+ dh_systemd_start -p bitlbee-common
else
- dh_installinit --init-script=bitlbee
+ dh_installinit -p bitlbee-common --init-script=bitlbee
endif
dh_installman
dh_lintian