aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 5 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index a00fdedf..9736e078 100755
--- a/debian/rules
+++ b/debian/rules
@@ -44,7 +44,7 @@ clean:
install: build
dh_testdir
dh_testroot
- dh_prep
+ dh_clean -k
dh_installdirs
$(MAKE) -C debian/build-native install install-etc DESTDIR=`pwd`/debian/bitlbee
@@ -62,9 +62,12 @@ binary-common:
dh_testdir
dh_testroot
- dh_installdocs --link-doc=bitlbee-common
dh_installchangelogs doc/CHANGES
dh_installexamples
+ dh_installdocs #--link-doc=bitlbee-common
+ # TODO: Restore --link-doc up here and remove the hack below once
+ # Hardy and Lenny are deprecated.
+ for p in bitlbee bitlbee-libpurple bitlbee-dev; do rm -rf debian/$$p/usr/share/doc/$$p; ln -s bitlbee-common debian/$$p/usr/share/doc/$$p; done
dh_installdebconf
dh_installinit
ifeq ($(DH_OPTIONS),-a)
@@ -81,7 +84,6 @@ ifeq ($(DH_OPTIONS),-a)
endif
dh_shlibdeps
ifdef BITLBEE_VERSION
- echo source:Version=1:$(BITLBEE_VERSION)-0 > debian/substvars
dh_gencontrol -- -v1:$(BITLBEE_VERSION)-0 -Vbee:Version=1:$(BITLBEE_VERSION)-0
else
dh_gencontrol -- -Vbee:Version=$(shell dpkg-parsechangelog | grep ^Version: | awk '{print $$2}' | sed -e 's/+[^+]*$$//')