aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorMarius Halden <marius.h@lden.org>2018-05-31 12:26:07 +0200
committerMarius Halden <marius.h@lden.org>2018-05-31 12:26:07 +0200
commitcaecc6deb160813d084e0a94099b42f434f7d9c9 (patch)
tree29df7bc72c79d01653b5fe87085477bf3c7c3637 /debian/rules
parentdb02ac8971379f9fee2f3a618bb08b8076d1a83d (diff)
parent49ab3cbbe3d8a92cced850dac46dec671433c5da (diff)
Merge branch 'master' into patched-masterHEADpatched-master
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules21
1 files changed, 6 insertions, 15 deletions
diff --git a/debian/rules b/debian/rules
index 8cdb9628..4fabddfa 100755
--- a/debian/rules
+++ b/debian/rules
@@ -34,22 +34,19 @@ CONFIGURE_OVERRIDES:=CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAG
HAS_DH_SYSTEMD:=$(shell dpkg-query -W -f='$${Status}' dh-systemd 2>/dev/null | grep -c "ok installed")
-# No difference at the build stage so just call main build target.
-# (Well indep could be docs-only but we prebuild them plus it's really
-# not that much work.)
-build-arch build-indep: build
+build-arch: build
build: build-stamp
build-stamp:
dh_testdir
mkdir -p debian/build-native
- ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent --otr=$(BITLBEE_OTR) --systemdsystemunitdir=/lib/systemd/system $(BITLBEE_CONFIGURE_FLAGS)
+ ROOT=$$PWD; cd debian/build-native; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --events=libevent --otr=$(BITLBEE_OTR) --systemdsystemunitdir=/lib/systemd/system --pcdir=/usr/lib/${DEB_HOST_MULTIARCH}/pkgconfig $(BITLBEE_CONFIGURE_FLAGS)
$(MAKE) -C debian/build-native
ifeq ($(BITLBEE_LIBPURPLE),1)
mkdir -p debian/build-libpurple
- ROOT=$$PWD; cd debian/build-libpurple; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --systemdsystemunitdir=/lib/systemd/system --purple=1 $(BITLBEE_CONFIGURE_FLAGS)
+ ROOT=$$PWD; cd debian/build-libpurple; $(BITLBEE_CONFIGURE_VERSION) $(CONFIGURE_OVERRIDES) $$ROOT/configure --debug=$(DEBUG) --prefix=/usr --etcdir=/etc/bitlbee --systemdsystemunitdir=/lib/systemd/system --pcdir=/usr/lib/${DEB_HOST_MULTIARCH}/pkgconfig --purple=1 $(BITLBEE_CONFIGURE_FLAGS)
$(MAKE) -C debian/build-libpurple
endif
@@ -97,10 +94,7 @@ binary-common:
dh_installchangelogs doc/CHANGES
dh_installexamples
- dh_installdocs #--link-doc=bitlbee-common
- # TODO: Restore --link-doc up here and remove the hack below once
- # Hardy and Lenny are deprecated.
- for p in bitlbee bitlbee-libpurple bitlbee-dev bitlbee-plugin-otr; do rm -r debian/$$p/usr/share/doc/$$p && ln -s bitlbee-common debian/$$p/usr/share/doc/$$p || true; done
+ dh_installdocs --link-doc=bitlbee-common
dh_installdebconf
ifeq ($(HAS_DH_SYSTEMD),1)
dh_systemd_enable -p bitlbee-common --no-enable bitlbee.socket
@@ -122,14 +116,11 @@ endif
dh_md5sums
dh_builddeb
-binary-indep: build install
- DH_OPTIONS=-i $(MAKE) -f debian/rules binary-common
-
binary-arch: build install
DH_OPTIONS=-a $(MAKE) -f debian/rules binary-common
binary-%: build install
DH_OPTIONS=-p$* $(MAKE) -f debian/rules binary-common
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary-common binary install
+binary: binary-arch
+.PHONY: build clean binary-arch binary-common binary install